Reply
Highlighted
Visitor
Posts: 13
Registered: ‎11-09-2017
Accepted Solution

Event Attribute in Audience stream

Hi, 

I would like to use a event-attribute to generate a Audience-Stream Attribute to create segments. But when I start an Audience Stream Trace I cannot get the information even though I get a "view"-event and there I can see the variable.

 

This is how I created the attribute in AudienceStream: 

event1.png

This shows that I cannot see any data for it during a Trace: 

event3.png

But I can see the variable in the event "view" during the trace: 

event2.png

 

Can you please tell me which mistake I do? 

Thanks,

Sophie

Reply
0 Kudos
Tealium Employee
Posts: 766
Registered: ‎09-01-2015

Re: Event Attribute in Audience stream

Hi @SKammerlocher,

Looking at your profile, there are 2 event_type EventStream attributes. One is a standard Universal Data Object (UDO) variable and the other is a Querystring Parameter (QSP). Your event_type_AS is using the QSP attribute which is the issue, you'll want to use the UDO attribute.

I found this by going to EventStream > Attributes and saw there were 2 event_type attributes. I expanded each and saw the UDO based attribute has 0 linked enrichments where as the QSP based attribute has 2 linked enrichments - 1 of them being to set event_type_AS. Then when I looked at your last screenshot I noticed that event_type is passed in the UDO section of trace and not the QSPs. 

Try this update and that should solve your issue!

Cheers,
-Dan

Visitor
Posts: 13
Registered: ‎11-09-2017

Re: Event Attribute in Audience stream

Hi @dan_george thanks for this solution. It works perfectly!

Reply
0 Kudos