Reply
Highlighted
Visitor
Posts: 1
Registered: ‎03-19-2018

Tracing Cart Abandonment Event - Not triggered when stopping trace

After adding an item to the cart and then stopping the trace before check out in order to test cart abandoment, the abandoment event is not captured. The trace log says "Visitor was forwarded to the appropriate actions and is waiting to be processed." - Shouldn't stoping the trace before checkout be an abandoment event and trigger that audience badge (if configured correctly)? - Therefore, if ending the trace before completing checkout does not trigger an event, does it means the audience and attributes are not configured properly? Or is this the wrong way to use trace to show cart abandonment?

Reply
0 Kudos
Tealium Employee
Posts: 85
Registered: ‎09-01-2015

Re: Tracing Cart Abandonment Event - Not triggered when stopping trace

Hi @Gannon619

The most straightforward way to implement cart abandonment is as follows;

https://community.tealiumiq.com/t5/Universal-Data-Hub/Cart-Abandonment/ta-p/10552

In any case, you should absolutely be able to use Trace, and trace end in the trace tool, to see everything happening.

A couple of notes;

1. When using trace end, it may take one minute or so for the "Visitor Session Ended" message to appear in the UDH trace UI, whereupon you will then see all the enrichments and actions you have configured.

2. Do you have a delay on your connector action?  i.e. Something like "Is In Audience At End of Visit, and delay action by 2 hours"?  If so, trace will show a message similar to what you are reporting here, I believe.  For debugging, I recommend removing the delay first, tracing that and verifying that the connector sends the data correctly, and then re-instating the delay.