dispatch_queue_debug_queued_dispatcher_not_ready

Rookie Contributor

I am trying to test an Android app and I am getting events queued, but never dispatching. In the decompiled class file, I am getting to:

dispatch_queue_debug_queued_dispatcher_not_ready

Which appears to be why I am not dispatching immediately.

PublishSettings: {
        battery_saver : true,
        dispatch_expiration : -1.0,
        enable_collect : false,
        enable_s2s_legacy : false,
        enable_tag_management : false,
        event_batch_size : 1,
        minutes_between_refresh : 15.0,
        offline_dispatch_limit : 100,
        override_log : "no override",
        wifi_only_sending : false
    }
val tealiumConfig = TealiumLib.Config.create(
            app,
            ACCOUNT_NAME,
            PROFILE_NAME,
            "dev"
        )
tealiumConfig.datasourceId = DATASOURCE_ID
tealiumConfig.forceOverrideLogLevel = "dev"
LifeCycle.setupInstance(INSTANCE_ID, tealiumConfig, true)
instance = TealiumLib.createInstance(INSTANCE_ID, tealiumConfig)

instance.trackEvent("test-event", mapOf())

Any ideas? Also is the Android SDK source code available to help with debugging?

4 REPLIES 4

dispatch_queue_debug_queued_dispatcher_not_ready

Tealium Employee

Hello there @wilwade-c5 !

 

Based off the information provided, it looks like both "tag management" and "collect" options are disabled in the profile you are connecting you. 

Because of this, no "dispatch" method has been selected, so the events will not be sent.

 

Using the "collect options" will send the information directly to eventstream, and the "tag management" option, will allow for the utag to run as you woudl typically expect, and your tags to run.

You can read more about these publish settings, and where to change them here.
https://community.tealiumiq.com/t5/Installation-Libraries/Mobile-Publish-Settings/ta-p/13633

If enableing this (and publishing after) doesn't work, let me know!

 

 

dispatch_queue_debug_queued_dispatcher_not_ready

Rookie Contributor
That was it! Thanks @LordLingham

dispatch_queue_debug_queued_dispatcher_not_ready

Bronze Contributor
Bronze Contributor

Even after activating the mobile library, I am getting this error. Could you please help me with this?

dispatch_queue_debug_queued_dispatcher_not_ready

Tealium Employee

Hello @asdhjjjjjjjjj 

Sorry to hear you are having some issues still.

If the mobile publish settings are correct, there could be something else blocking things from firing, This may be due to things like the network connection, the old mobile.html file being cached, or something like "consent manager" is set up within the app.

 

Have a quick check of those things and if you still do not find the fix, reach out to the support team who will be happy to look in to this further / at your specific setup.

 

Thanks

James

Public