utag.link() variables not working with Audience Stream

Gerhard_TUI
New Member
Gerhard_TUI

Hi,

 

I have a rule which is adding numbers when somebody uses the filters.

We are firing a utag.link() and the values are tracked in Google Analytics. So it looks like that it is firing correctly.

But the rule in Audience Stream is not working.

 

Example:

If user is filtering after Gästetyp and Familien here:

https://www.robinson.com/de/de/cluburlaub/

 

What could cause the problem?

 

Rule is If any event ga_event_action = familien then fire.

 

Thanks in advance.

 

Best regards,

Gerhard

7 REPLIES 7

utag.link() variables not working with Audience Stream

loldenburg
Contributor
loldenburg
Could it be that the ga_event_action is scoped only to the Google Analytics Tag? Then Aud Stream will not know about it.
Highlighted

utag.link() variables not working with Audience Stream

Gerhard_TUI
New Member
Gerhard_TUI

Thanks @loldenburg.

I thought utag.link() is automatically firing the Google Analytics Event Tracking.

How can I scope the utag.link() call to Audience Stream?

utag.link() variables not working with Audience Stream

loldenburg
Contributor
loldenburg
utag.link() is automatically firing Audience Stream: You can see the request to "i.gif" in the Network tab or in your HTTP Debugging tool.

I don't know how your Tealium account is set up, so it is hard to debug from here, but usually, every UDO variable you set in a non-tag-scoped extension (e.g. an Extension scoped only to Google Analytics which is what I am supposing here) is automatically sent to Aud STream as well.

So check the Extension that generates these ga_event_action UDO variables and check if the Extension is scoped to "All Tags" or just to "Google Analytics". If the latter is the case, add Tealium Collect to the scope or switch to "All Tags" (depending on your setup and other tags used, this may not be sensible.

Note on the side: In general, I prefer generic variable names over tool-specific ones. "ga_event_action" sounds as if some value exists only sensibly for GA. But the Event Action or Event Category contain information that is not only interest and relevant for Google Analytics, any Analytics tool or Audience Stream may use them. I would only name UDO Variables "ga_something" if they are for GA only (now and in the future), e.g. the GA Property ID which makes no sense for any other tool.

utag.link() variables not working with Audience Stream

Gerhard_TUI
New Member
Gerhard_TUI

hmm...

i don`t see the i.gif firing. The utag.link() is fired not through an extension but via code.

Do I need an extra extension - because the event values in the utag.link() were sent to Google Analytics.

I am confused.

 

In addition:

I just read the help.

https://community.tealiumiq.com/t5/JavaScript-utag-js/Event-Tracking-Options-with-utag-link/ta-p/155...

They recommend to use "event_name" what I don`t use. Is that the cause maybe?

 

Regarding the naming you are right. Thanks!

utag.link() variables not working with Audience Stream

loldenburg
Contributor
loldenburg
No, that should not make a difference. Audience Stream usually takes any data that was available in All Tags Extensions. Hard to say from here what the external code that causes utag.link to fire does, but in theory, it should also fire i.gif.

If you go to the Developer console (F12 in CHrome) and type
utag.link({'blabla':'bla'})
Do you still not see an i.gif request?

Then your Tealium Collect tag may need some reconfiguration. Open a support ticket, Tealium should help you onboard Audience Stream, it should be in their interest that clients do not struggle as much with the setup.

utag.link() variables not working with Audience Stream

Gerhard_TUI
New Member
Gerhard_TUI

You made my day! 

 

The collect tag was scoped wrong. I see the i.gif now and the event is calculated now in Audience Stream.

Everything is fine. Thumbs up. Thanks for your support :-)

utag.link() variables not working with Audience Stream

loldenburg
Contributor
loldenburg
ok great to read!