Adscale retargetting tag bug

Tealium Expert
Tealium Expert

It seems to be a small but troublesome bug in the Adscale retargetting tag code. In the pixel URI, the parameters are not separated from the adress with the questionmark but with the ampersand:

instead of


I run the latest tag version. What would be the quickest way around this, while waiting for a new tag version?





Adscale retargetting tag bug

Tealium Employee

I don't see Adscale in our Tag Marketplace.


Are you loading this using the Tealium Generic Tag?




Adscale retargetting tag bug

Employee Emeritus


Thanks for helping us identify a bug in the Tealium Pixel Container.  The bug has been logged and at some point in the future it will be resolved. 


You have two options to resolve the issue in your profile. 


1) You could implement a Generic Tag instead of a Pixel Container.  This option will require you to create an extension with the Math.random() logic and pass this in via mappings.

2) You can modify the Pixel Container Template in your profile.


The problem is the line of code:

x += "&" + u.cachevar + "=" + Math.random();

It should be this:

x += (x.indexOf("?") === -1 ? "?" : "&") + u.cachevar + "=" + Math.random();

Let us know if this fixes your issue.

Adscale retargetting tag bug

Tealium Expert
Tealium Expert

Thanks a lot guys, you are great!

Problem solved and German webmasters happy again.