Highlighted

Categories Enhanced E-Commerce

Silver Contributor
Silver Contributor

Hello everyone,

 

I'm experiencing some problems with the Google Analytics Tag at the moment. I'm trying to map my data sources to the "product_category"-variable in the GUA-Tag.

As described in the Google Analytics Documentation (https://developers.google.com/analytics/devguides/collection/analyticsjs/enhanced-ecommerce#product-...) we are using slashes as delimiters to separate our five different data sources with the Join Data Values Extension.

The combined Value works fine with Web Companion and is displayed in the way it should look like in the data layer, but Google Analytics will receive only the first letter of the value, f.e. "Clothing/Shirts/Polyester" it will only receive "C".

 

I already tried to use only one data source, to try if it is about the Join Data Value Extension, which lead to the same result.

 

Anyone else ever had this problem and knows how to fix it?

 

Thanks in advance

3 REPLIES 3
Highlighted

Categories Enhanced E-Commerce

Employee Emeritus

Hello @IWAG_FSchl. Have you taken a look at this document?

 

https://community.tealiumiq.com/t5/Tags-and-Client-side/Google-Universal-Analytics-Tag-Enhanced-E-Co...

 

I'm hoping this can help you solve some of your issues. Please let me know. Thank you. 

Remember to give me a kudo if you like my post! Accepting my post as a solution is even better! Also remember that search is your friend.
Highlighted

Categories Enhanced E-Commerce

Tealium Employee

@IWAG_FSchl, the tag template is expecting an array for the "product_category" variable. If the list of values is already in an array in your data layer, you don't need to use the Join Data Values Extension.

Hope that helps.

Thanks,
Adam

Highlighted

Categories Enhanced E-Commerce

Silver Contributor
Silver Contributor

Hi @adam_wolfers,

 

thank you for your answer.

 

We have five seperate values which we want to track all for themselves, aswell as combined as category. This is why I had to use the join data extension.

 

But as you described, we noticed that not all of our datasources were arrays. Seems like it works now with setting all values to arrays instead of strings. 

 

Thanks and bye