Highlighted

GA In-Page Analytics not working

Rookie Contributor
I get the following message when trying to get to the In-Page Analytics report: "Your site doesn't load ga.js or analytics.js from Google. If you host the Google tracking code on your own servers, it isn't updated automatically and can miss important changes." My tag set-up has the Script Source of Tealium. If I change this to Google (External), will this impact anything? Thanks.
2 REPLIES 2
Highlighted

GA In-Page Analytics not working

Employee Emeritus
The in-page analytics should be working, but as a best practice we do recommend clients use the Google-hosted version for their tags. Unrelated, based on your description you are likely using Google Analytics "classic." I'd highly recommend making the migration to Universal (the migration will be required by Google within the next 2 years or so). You might get a slightly slower load time for the GUA tag since it's an additional request for the library, but this will be cached on subsequent pages so the overall impact is negligible.
Highlighted

GA In-Page Analytics not working

Rookie Contributor
For me In-Page-Analytics does not work in the embedded mode (in report tab itself), only in the full view mode (new tab). And what made me think, it is not working at all is a bit weird, so I thought I should share that: the first page view in the full view mode never has any data. I have to navigate to any other page on my website to see any data overlay. Even the homepage with previously zero pageviews displays data after navigating back to it. This not very elegant, but it works.