Highlighted

Google Analytics collect tag not firing

Silver Contributor
Silver Contributor

I have implemented tealium on my local machine but the Google analytics tags are not firing for page views and events. I see analytics.js loading on the site but the collect tags are not visible. Can anyone explain why is it happening. I looked at every possible solution including tracking code and property IDs but couldn't find the cause of the tag not firing.

3 REPLIES 3
Highlighted

Google Analytics collect tag not firing

Tealium Expert
Tealium Expert

Hi @sujay_das - check out the browser inspector elements tab and network tab, you won't see the tags injected by Tealium in the View Source.  You'll see the tags in the Elements tab of the inspector and the actual pixel requests in the Network tab.  In Elements, do a find on 'utag.js' to get started.  Ensure that the utag.js tag snippets are placed as recommended within the source code of your page(s).

Also check the Console tab to note any errors - that tab can provide many clues to resolve the issues you reported.

Also be sure to try the Tealium tools (Chrome plugin) and Google Tag Assistant chrome plugin to help you diagnose.

 

 

Highlighted

Google Analytics collect tag not firing

Tealium Employee

@sujay_das

Also to note, many of the analytics tools don't like IPs. So if you are developing locally it would be worth updating you hosts files So that a valid domain is used in the URL.

Adrian

Ask me anything Tealium related or Javascript, or NodeJS.
Please remember to mark solutions as accepted for future searchers.
Highlighted

Google Analytics collect tag not firing

Silver Contributor
Silver Contributor
Hi @adrian_browning,

The issue is resolved now after I pushed the code to an environment. Maybe it was expecting a domain name in the page URL to fire the tags.
Thanks for the solution.