JQuery 1.9 support

rohan_x_kapoor_
Not applicable
rohan_x_kapoor_
One of the websites I'm working on is using JQuery 1.9. I'm leveraging the JQuery Handler 1.7 extension which is supposed on work on versions higher than 1.7. I've tried every possible way to get the JQuery handler to work but it doesn't. I tried the JQuery selector value which didn't work and also tried adding the class name which is #pod watch-now-itunes externalLaunch which also didn't work on both click and mouseover. Any ideas? Thanks, Rohan
4 REPLIES 4

JQuery 1.9 support

Tealium Employee
Hi Rohan, I just did a very simple test using jQuery 1.9.1 and it seems to work OK. jQuery 1.9.1 does support the "on" event handler. I'm guessing there is an issue with the selector itself or possibly a timing issue where the item is not in the DOM yet when the Extension runs (at DOM Ready.) If the item is added to the DOM later, you may need to use the delegated events feature (I haven't done this myself.. yet.. :-) This will be a JS Extension (done in code form) as detailed in their documentation below. http://api.jquery.com/on/ "Delegated events have the advantage that they can process events from descendant elements that are added to the document at a later time."

JQuery 1.9 support

son_hoang
Employee Emeritus
son_hoang
Hi Rohan, could you please give us with the HTML code you're testing the selector with, as well as the value(s) you're using for the jQuery selector?

JQuery 1.9 support

jared_hislop
Employee Emeritus
jared_hislop
Hey Rohan, Can we access the page and button so we can play around a bit and see what is happening? Thanks
Highlighted

JQuery 1.9 support

Tealium Employee
Thanks for the update Rohan.. I appreciate you closing the loop on this.