Highlighted

Lagging profile loads?

Silver Contributor
Silver Contributor
I have over 100 tags and extensions on one of my profiles. I definitely plan on consolidating most of them but as media campaigns and tracking become more apparent (not relying on internal IT to help), my tagging and extension usage will increase. It currently takes a minute or so to load the profile and it is slow to respond when making active changes. Am I the only user experiencing this?
15 REPLIES 15
Highlighted

Lagging profile loads?

Employee Emeritus
Landin, are you talking about the profile loading within the Tealium iQ console?
Highlighted

Lagging profile loads?

Silver Contributor
Silver Contributor
Correct, within the Tealium iQ console. Sorry for not clarifying.
Highlighted

Lagging profile loads?

Employee Emeritus
Thanks Landin, I've asked people smarter than me to weigh in on the question.
Highlighted

Lagging profile loads?

Tealium Employee
Which profile is experiencing this issue? The overall loading of the profile should be based on basically just the size of the profile. If there is a lot of publish history for example, or a lot of large code extensions, the load of the profile may take longer, but it still should be very fast.
Highlighted

Lagging profile loads?

Tealium Employee
Landin, we're investigating. We've looked at other profiles and they load very fast but the aaa/main profile does seem to take longer than expected. I benchmarked against our known largest profile and the largest profile loads faster. It could be a indexing issue on the datastore, but rest assured we're on it.
Highlighted

Lagging profile loads?

Silver Contributor
Silver Contributor
Awesome, thanks guys.
Highlighted

Lagging profile loads?

Employee Emeritus
Thanks Mike!
Highlighted

Lagging profile loads?

Employee Emeritus
Landin, how many extensions are you running on the profile?
Highlighted

Lagging profile loads?

Silver Contributor
Silver Contributor
Over 150 because due to a ton of media tags that require specific tags. I can consolidate a few of the tags and use Extensions to fire them. That will cut down the number of tags, but I haven't had the chance to do so. I'd say 1/3 of the extensions are custom Site Catalyst items.
Highlighted

Lagging profile loads?

Tealium Employee
I don't think the delay is a result of the tags or extensions, or even the network. It looks to be a JSON parsing issue once the profile is retrieved, and what is different with yours is you have a lot of versions, and we keep track of a lot of version history.
Highlighted

Lagging profile loads?

Tealium Employee
An easy test would be for us to copy your profile over, and remove all but the last 10 publishes and see what happens.
Highlighted

Lagging profile loads?

Employee Emeritus
OK Mike, I'll hold off until we have results back from the tests I know the team are running :-)
Highlighted

Lagging profile loads?

Silver Contributor
Silver Contributor
Much appreciated guys

Lagging profile loads?

Tealium Employee
I cut down the publish history to the last 30 versions. I still have all the data if you need it, but the last 30 should be sufficient. This is a very big profile. I was able to get it to load faster, but I'm still not happy with the results. We're moving in the direction of having these things load on demand, but for right now we load the entire profile. We'll put the enhancement in place to load the history of the last N versions by default soon. Until then, it's a bit faster. You have some JavaScript code extensions in place that are un-used. Anything you can do to cut down the profile size will reduce the load time.
Highlighted

Lagging profile loads?

Silver Contributor
Silver Contributor
Hi everyone, so the parsing issue helped a bit on the load time but after a few days, it went back to the long load times. It was mentioned that it was due to the 150+ tags and extensions. As time goes on, more tags and extensions will be created. Any suggestions on improving the load time? Much appreciated!