Highlighted

No utag .js on page

Rookie Contributor

Most of the time i ran into the problem while switching the environment.Why do I get this .How to troubleshoot.

 

2 REPLIES 2
Highlighted

No utag .js on page

Tealium Expert
Tealium Expert

Hi @sandeshi,

What tool are you using to switch the environment? "environment switcher" in Tealium custom tools or Web Companion?

Couple of things I would recommend to check - 

  • Make sure the environment which you are switching has the utag.js present or published in that environment
  • Check its not blocked by your application/webpage
  • if you are wworking on proxy check weather your proxy is blocking it.
  • Check if there are any error which is causing not to load on that page.

Hope this helps.

Thanks!

Highlighted

No utag .js on page

Tealium Expert
Tealium Expert

Hi @sandeshi - I've had this happen on sites I've inherited and if you can see the "utag.js" in the html source when you do View Source in the browser, then you might want to see if there's errors in the console and check to see that the UDO has been declared on the page above the reference to utag.js.

 

I've worked around the UDO not being present by adding a Tealium extension to dynamically inject it.... this is when whoever installed the Tealium container tag missed adding the utag_data {} statement.

Add the following in a JavaScript extension and scope it to Pre Loader.

if(!window.utag_data) {
  window.utag_data={}
}
// utag_data show up in web companion

You can also paste the above into the browser console when you get the utag.js not present error and note if after executing, does the Tealium Web Companion come up.  A quick way to test.

 

Good luck - let us know how it goes...