Highlighted

Optimzely is blocking utag to start other utags

Rookie Contributor

We're loading optimizely as an async script as we do with any other utag script. We followed the guide that can be found on optimizely itself. 

Optimizely is loaded but it seems that utag loader doesn't pick this up. The utag script waits 3000ms (forcetimeout) until the rest is being loaded. When I use the tealium tag helper it says that optimizely is loaded, all other tags say OK.

 

This is wat the logs of tealium give me on the page:

utag.loader.LOAD:add sender-48
utag.js:formatted:423FORCE:[object Object]:[object Object]
utag.js:formatted:423FORCEERROR:46
utag.js:formatted:423e:load error , s://cdn.optimizely.com/js/1234567.js?utv=ut4.009.xxxx , l:0 , t:le ,
utag.js:formatted:423utag.loader.LOAD:46
utag.js:formatted:423utag.loader.LOAD:add sender-46
utag.js:formatted:423CLEAR FORCE
utag.js:formatted:423utag.handler.INIT
utag.js:formatted:423trigger:view
utag.js:formatted:423All Tags EXTENSIONS

4 REPLIES 4
Highlighted

Optimzely is blocking utag to start other utags

Employee Emeritus

Wardpeet,

A couple of days have gone by and no general response.  I am guessing because most of us want to see more detail on this complex issue.  I would recommend you reach out to your Tealium Account Manager to get a Tealium Engineer to look at your specific website to walk through some debugging steps.  If you find out what the issue is, we would love to hear back from you with details.

 

Brian

Highlighted

Optimzely is blocking utag to start other utags

Rookie Contributor

@brian_kranson I added some pictures, hopefully they are here to stay (hosted on my dropbox) so after a few months they are probably gone. As you can see on the timeline below that there is a delay that causing utag to do their thing. For example utag7 should insert another js script in the page but they are waiting for optimizely to give an ok. Optimizely never gives an ok so the scripts wait 3000ms until they execute. it's the forcetimeout that you can specify when publishing.

 

This is the delay i'm talking about:

 

This is what web companion says:

 

This is the telaium tag

Highlighted

Optimzely is blocking utag to start other utags

Tealium Employee

Hi Wardpreet

 

Force timeout doesn't do what you think it does.  If you read the description in the UI alongside that setting, you will see that it is designed to prevent a tag that is taking too long to "load", not one that is taking too long to "fire".  As noted in the description, this is only relevant when libraries are loaded on-premise or from a custom location.  i.e. it doesn't really apply when the tags are being loaded from Tealium's CDN.

 

I'd suggest that you get in touch with your account manager, or email support@tealium.com with details of your account and profile, so that we can have a look at the problem specifically

 

Mark

Highlighted

Optimzely is blocking utag to start other utags

Rookie Contributor

Hi @mark_reddin,

 

Thank you for your answer. It has to do with force timeout because when we lower it or make it bigger the gap between our utag and third party scripts evolves the same way.

 

I'll ask my account manager to send it over to your support.

 

Regards,

Ward