Pixel Container Tag does not fire without an IFRAME?

Tealium Expert
Tealium Expert

We use the generic Tealium Pixel/Ifram container tag sometimes to fire simple pixels. They have, until now, always been used with the IFRAME setting. Now I have changed one pixel to fire as a IMG, since the vendor want's that instead. But, it doesn't work, it still renders as an IFRAME. (And yes, I have the latest template version.. :-)

 

I read in a support document:

 

From the 'Type' drop-down list, select the type of pixel, either image or iframe.

  • If you select image, be aware that the expected response is an image. The Tag will not work if the response is not an image.
  • If you select iframe, the response can be any type of HTML.

Does this mean that the responding server (with Adscale) is not configured to receive this without an IFRAME?

 

 

4 REPLIES 4
Highlighted

Pixel Container Tag does not fire without an IFRAME?

Employee Emeritus

@per_lundqvist,

 

You should consult with your tag vendor rep if they accept <img> tags.  

 

In addition, if you originally were using the IFRAME setting, you will have to drop the template to grab the IMG version of the template.  My guess is you have the latest template, but it may still be the IFRAME version.

Highlighted

Pixel Container Tag does not fire without an IFRAME?

Tealium Expert
Tealium Expert

It is the vendor who has asked us to change from IFRAME to IMG @meng_lim.

 

Why can't I just change the template setting accordingly? What do you mean with "grab the IMG version of the template" and "..the IFRAME version"? I thought the template settings change the rendering of the tag code.

Highlighted

Pixel Container Tag does not fire without an IFRAME?

Employee Emeritus

@per_lundqvist,

 

When you first add and configure the Tealium Pixel (or Iframe) Container, the tag template will auto-generate depending on the setting you selected (e.g. Iframe or Image) on your first publish.

 

If you've selected "Iframe" then the template code that gets generated will be for firing an <iframe> pixel.  If you decide to change it to an "Image" then you will need to drop the template so that the template code will get re-generated for the <img> pixel.  Otherwise, it will continue to fire an <iframe> pixel.

 

When you first switch the configuration, there should be a warning alert box that pops up to remind you to drop the template.

 

Steps to update the template:
1. Change the drop down selection to "image"

 

01_pixel_container.png

 

2. A notification box will pop-up. Click "OK".

 

02_pixel_container.png

 

3. Go to Edit the Tag Configuration > Advanced Settings > Edit Template

 

03_pixel_container.png

 

4. Click on "trashcan" icon located in the upper-right corner

5. Click on "Save Profile Template"

 

04_pixel_container.png

 

6. Publish to your target environment (e.g. DEV, QA and/or PROD)

 

Let me know if this does the trick for you.

Highlighted

Pixel Container Tag does not fire without an IFRAME?

Tealium Expert
Tealium Expert

Didn't know about this "feature", but it certainly did the trick. Thanks a lot!