Highlighted

Problems with Lookup Tables and Umlauts

FelixHartmann
Bronze Contributor
Bronze Contributor FelixHartmann

Hi,
I'm currently using a lookup table extension to map cities to their Ids.

The contains operation fails to work, if there are umlauts in the city-name.

Is there a known issue or best practice for handling this?

 

The ASCII-codes of both the JS-variable and the entry of the lookup table are identical.

 

Best regards,

Felix

3 REPLIES 3

Problems with Lookup Tables and Umlauts

Tealium Expert
Tealium Expert

Hello @FelixHartmann,

 

UTF-8 encoding needs to be turned on in publishing in order to get the umlaets to work! Please find below the link to document to configure UTF-8 encoding.

 

https://community.tealiumiq.com/t5/iQ-Tag-Management/Publish-Configuration/ta-p/13632#implementation

 

Let us know if this helps. Happy to assist any further.

 

Thanks

Abraham

Problems with Lookup Tables and Umlauts

tamedbeast
Silver Contributor
Silver Contributor tamedbeast

I could not have said it better myself @abrahameaso! #hugs

If you liked it then you should have put a kudo on it!

Problems with Lookup Tables and Umlauts

kathleen_jo
Employee Emeritus
kathleen_jo

Hi @FelixHartmann. To add on to @abrahameaso's answer above, please find this further discussion about UTF-8. Just in case you would like further bedtime reading. ;-)

Remember to give me a kudo if you like my post! Accepting my post as a solution is even better! Also remember that search is your friend.