Highlighted

SDK Implementation not firing tags

Rookie Contributor

Hi,

We are currently implementing the SDK on iOS (swift) and we just want to track a couple of events, such as first login and push notifications as the majority of the app is a web-view and will have it's own container (different profile) so the tracking is enabled on demand for single events and not permanently. We did a couple of tests and the log seems to be ok with something like this...

▶️[Track #7]: TEST

=====================================

Module Responses:

1. tagmanagement: SUCCESSFUL TRACK ✅

And the payload with all the corresponding information...

But despite having configured multiple tags over the iq management profile (3 different tags for GA) no hit is sent to GA, no real time data is seen in the respective property.

Any ideas on what may be happening here? How can I debug the excecution of this rules, I currently don't know if the hit is being fired and being blocked some where or not firing at all. Any recommendations on what to raise to the developer in terms of debugging?

Tests were made both in emulator and then deployed in a physical phone.

Thanks,

Felipe

1 REPLY 1
Highlighted

SDK Implementation not firing tags

Tealium Employee

Hello @fids

 

Sorry to hear you are having some issues with this.

 

I would recommend opening Safari and using the "developer" menu to access the webview which is created by the Tealium SDK (as you are using the 'tagmanagement' option)

This will allow you to view the instance of utag.js which is loaded, and will allow you to see. all the events pass through, giving you the chance to place any breakpoints needed to evaluate extensions, tags and loadrules, as well as any network requests sent out to GA.

 

 

Alternatively you can load the mobile.html file the app loads, in a normal browser window, without the app.

You would need to send the event in the console manually, so a bit more work, but helpful if you dont have the app handy.