Highlighted

Tag is loaded but not fired

Gerhard_TUI
Visitor
Gerhard_TUI

Hi,

 

I have some tags which are loaded but not fired, here:

https://www.robinson.com/de/de/angebot/?hotelOnly=1&productCodes=VOA42061,SZG87041,LNZ42061,KLU25062...

 

I don`t see the problem, there are no problems shown in the console. And on other sits it is working correct.

 

Do you have any ideas?

 

Thank you.

Gerhard

5 REPLIES 5

Tag is loaded but not fired

Tealium Employee

Hi @Gerhard_TUI

 

So looking on the page in question, there is a utag_cfg_ovrd set with  noview = true.

This is what is stopping the tags from firing. You need to explicitly call utag.view();

 

Adrian

Ask me anything Tealium related or Javascript, or NodeJS.
Please remember to mark solutions as accepted for future searchers.

Tag is loaded but not fired

Srinivasan
Super Contributor
Srinivasan Super Contributor

Hello @Gerhard_TUI

 

Please find below link to know explicit intended to window.utag_cfg_ovrd.

 

https://community.tealiumiq.com/t5/Tealium-iQ-Tag-Management/Where-can-I-find-a-list-of-utag-cfg-ovr...

 

Hope this helps!!!

Tag is loaded but not fired

Gerhard_TUI
Visitor
Gerhard_TUI

Thanks. 

I changed it to noview = false and it is working.

Tag is loaded but not fired

UC06526
Visitor
UC06526

Hi @adrian_browning,

I had the same issue here and it solves setting noview to false.
But, I need noview = true for data analytics purpose.

Is there a way to fire Tealium tag with noview = true?

Thanks,
Dayan

Tag is loaded but not fired

Tealium Employee

@UC06526

To set utag to have the noview active you would:

  1. Create a JS Extension scoped to Preloader
  2. Add the code
    window.utag_cfg_ovrd = window.utag_cfg_ovrd || {}; 
    window.utag_cfg_ovrd.noview=true;

By default utag will run with noview set to false, so you don't have to manually set this.

Adrian

Ask me anything Tealium related or Javascript, or NodeJS.
Please remember to mark solutions as accepted for future searchers.