Highlighted

Upgrading Adobe AppMeasurement from version 1.6.1 to 2.6.0 - Visitor API issue

Silver Contributor
Silver Contributor

Hi Team,

We just upgraded from Adobe AppMeasurement version from 1.6.1 to 2.6.0.

Strangely, we observed that "Visitor API" module (function Visitor(){...}) isn't included in the the latest adobe template(2.6.0). Because of this our "mid" parameter is lost. 

Is there any specific reason why "Visitor API" isn't included in 2.6.0 and it exists in v1.6.0 ?

I also have seen that there is a tag in marketplace "Adobe Marketing Cloud ID Service" which serves as Visitor API. 

Do we need to use this new tag when we upgrade our Adobe templates to version(2.6.0) or more ?

Thanks

Ravi

1 REPLY 1
Highlighted

Upgrading Adobe AppMeasurement from version 1.6.1 to 2.6.0 - Visitor API issue

Tealium Employee

Hi @ravi_thati

 

You are correct with the latest version of the Adobe AppMeasurement tag, we have extracted the Visitor Service code and made this into its own tag. This was because multiple Adobe tags were referencing the same code, however, the configuration was limited.

You will indeed to add the "Adobe Marketing Cloud ID Service" tag before your AppMeasurement tag. Once this is done, they will hook into each other and start the process of sorting out the mid, parameters.

Adrian

Ask me anything Tealium related or Javascript, or NodeJS.
Please remember to mark solutions as accepted for future searchers.