Highlighted

Vague question... what would unset an evar on utag.view?

Tealium Expert
Tealium Expert

On a certain page of my site I have a particular eVar value which is set properly upon page load.  If the visitor clicks a certain element, this triggers utag.view and another page view is recorded but the previously set eVar is no longer set (so it isn't sent) however other variables are properly set and sent.  URL doesn't change - it's an on-page image gallery.

 

I was using this fantastic debug info:

  https://community.tealiumiq.com/t5/uTag/Debugging-utag-view-and-utag-link/ta-p/13695 and I can see that the mapped variable data for the evar is set, but the evar does not receive the value on these "intra page" view calls.

 

I want to watch the values of certain eVars just before the Adobe tag is fired. It is as if this certain eVar variable is being un-set while other variables correctly remain populated or are re-populated when utag.view fires.

 

Any input is welcome.

 

Thanks very much!

 

MitchellT

4 REPLIES 4
Highlighted

Vague question... what would unset an evar on utag.view?

Tealium Expert
Tealium Expert

Replying to my own post here....  what I am experiencing seems a little like what is described in this post. 

 

https://community.tealiumiq.com/t5/Tealium-iQ/utag-link-utag-view-and-utag-data-persistence/m-p/5197...

 

Folks posting there alluded to an update - any news about that?

 

Thanks - 

Highlighted

Vague question... what would unset an evar on utag.view?

Tealium Employee

@mitchellt

 

The update that I was referring to on the other post, has now been released.

And is available in the latest utag version (v4.40).

 

https://community.tealiumiq.com/t5/uTag/How-do-I-upgrade-to-the-latest-utag-js/ta-p/5042

 

Adrian

Ask me anything Tealium related or Javascript, or NodeJS.
Please remember to mark solutions as accepted for future searchers.
Highlighted

Vague question... what would unset an evar on utag.view?

Employee Emeritus

Hi @mitchellt. Here are some release notes on 4.40. 

 

https://community.tealiumiq.com/t5/uTag/utag-js-version-4-40-Release-Notes/ta-p/12946

Remember to give me a kudo if you like my post! Accepting my post as a solution is even better! Also remember that search is your friend.
Highlighted

Vague question... what would unset an evar on utag.view?

Silver Contributor
Silver Contributor

@mitchellt, for Adobe specific you should check if you have the clearvars option set to yes (edit sitecatlyst tag and look for dropdown for clearvars) If set to yes, the first call will set the variables and after the request is done, all the variables are cleared. In subsequent requests you will have to send ALL the variables in the utag.view/link call in order to have them send again. Disable the clearvars option and check if this resolves your issue. Happy testing!