Variables mapped in AT Internet tag but not populated on my website

alicehenot
Silver Contributor
Silver Contributor alicehenot

Hi all,

 

I set up an AT Internet tag on a website and mapped some variables. All the variables have been added to the data layer.

 

When I check the source code of the website, my variables are in my utag.data but are not populated.

 

Code:

<script type="text/javascript">
			var utag_data =	{"site_name":"586638","site_section":"1","page_section":"transfer_dsb","page_category":"","page_subcategory":"","page_name":"transfer_dsb","page_type":"","env_type":"qa","language":"2","customer_id":"353","car_type":"","customer_firstname":"","customer_lastname":"","email_address":"","phone_number":"","city":""};
  			</script>
			
			<script type="text/javascript">
			    (function(a,b,c,d){
			    a='//tags.tiqcdn.com/utag/totalms/middleeast-total/qa/utag.js';
			    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
			    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
			    })();
			</script>
 

I can't understand why. Maybe some of you will have an idea?

 

Best regards,

Alice

8 REPLIES 8

Variables mapped in AT Internet tag but not populated on my website

Tealium Expert
Tealium Expert

Hello @alicehenot,

 

Are you using extensions to set the values to data layer or data is set on the page in utag_data object as shown in your post below?

 

If the values are not shown for the variables set through extensions, following is my suggetion to check if value is set on the correct variable depending on the scope of the extension.

 

PreLoader scope: references utag_data. Only here should you be adding data to this object. utag_data is only read once during initial utag.js execution and on an SPA page would only be read once initially when your app loads. On route changes this object is not read.

DOMReady scope: Here you can reference utag.data
All Tags or Individual Tags scope: Before or After Load Rules: b object

 

Hope this helps.

 

Thanks & Regards

Abraham

Variables mapped in AT Internet tag but not populated on my website

alicehenot
Silver Contributor
Silver Contributor alicehenot

Hello @abrahameaso,

Thanks for your reply.
My data are indeed set on the page in utag_data object wihout using any extension.

Variables mapped in AT Internet tag but not populated on my website

tamedbeast
Silver Contributor
Silver Contributor tamedbeast

Hey @alicehenot. If you liked it maybe you should have put a ring, I mean an accepted solution, on it?

#winkwink

#teehee

If you liked it then you should have put a kudo on it!

Variables mapped in AT Internet tag but not populated on my website

kathleen_jo
Employee Emeritus
kathleen_jo

@tamedbeast!!!! <sigh>

 

Sorry @alicehenot. Our little mascot can get a little carried away sometimes. Let us know if you have any other questions. We are here to help. 

Remember to give me a kudo if you like my post! Accepting my post as a solution is even better! Also remember that search is your friend.

Variables mapped in AT Internet tag but not populated on my website

alicehenot
Silver Contributor
Silver Contributor alicehenot
Hi @tamedbeast! Yes for sure, would keep that in mind!

However I haven't solutioned my issue yet, as my variables are not set through extensions so I can't applied the suggested solution.

Still investigating!

Variables mapped in AT Internet tag but not populated on my website

Tealium Expert
Tealium Expert

Hello @alicehenot,

Thanks for clarifying.

I hope you have created data element for each utag_data object data layer variable under "Data Layer" tab with data type as UDO variable. Also mapped that data layer variables in the AT tag "Data Mappings" section.

Let me know if this is already done and still you are facing issues in seeing data in the AT tag triggered

Thanks
Abraham

Variables mapped in AT Internet tag but not populated on my website

alicehenot
Silver Contributor
Silver Contributor alicehenot

Yep, I created all my variables and added them to the data layer under the datalayer section.
They are all UDO variables.

Then I mapped them in my AT Internet under the tag section.

As you can see in the piece of code I share, extracted from the source code of the website, the variables are called by Tealium, but not populated.

I can't understand where in the process I missed a step...

Thanks @abrahameaso!

Variables mapped in AT Internet tag but not populated on my website

Tealium Expert
Tealium Expert

Hello alicehenot

 

May be something got fixed:), I had a chance to test the utag code provided on test site and glad that i was able to notice some of the data passed in the tealium data layer. for Eg. page name, level2, language data in the reqest sent from the browser. Here is a screenshot with variables showing values. 

 

Hope this helps. 

AT Internet Smart tag.png

 

AT Internet Smart tag.png