Highlighted

custom metric not being captured

Silver Contributor
Silver Contributor

Hi all,

 

we are facing an obstacle in capturing variable as a custom metric in Tealium. Basically, we have a timer extension for interval of 5 seconds lasting for 90 seconds and it fires correctly. We want to capture time spent on a page as a custom metric (5, 10, 15, 20 seconds etc.). Given that, we created an UDO variable called "timer" and we capture that information there when we tried in Console.

Then we created another UDO variable "timer_metric" and used set data extension to set this variable from variable "timer". The variable "timer_metric" we mapped to custom metric but it does not work and custom metric is not being sent.
Any help is much appreciated.
Thank you,

 

Lukas

7 REPLIES 7
Highlighted

custom metric not being captured

Bronze Contributor
Bronze Contributor

Hi Lukas,

 

I'm not so great at the technical stuff but could the problem be that the value (5, 10, 15, ...) is generated after your datalayer is loaded. So whenever you enter the page, the value in your datalayer will always be 0. 

It might work using the utag.link()/utag.view() functions, but be aware that it might be tricky. 

 

cheers,
Devid

 

 

 

 

 

 

 

Highlighted

custom metric not being captured

Silver Contributor
Silver Contributor

Hi David,

 

thank you for your idea.

Actually, we use the custom javascript extension for the timer and in that function we also define a new UDO variable. We use utag.link() for that. It works to define the UDO variable. The problem is that even if the variable is mapped to custom metric in our GA tag it simly does not fire. When we look on the developer console, the variable is populated according how much tome passed but information is not being sent as custom metric.

Cheers,

Lukas 

Highlighted

custom metric not being captured

Tealium Employee

Any event in GA requires 'event action' and 'event category' to be sent on the utag.link call.  This can be easily overlooked when first setting up events to fire GA.  

 

This is a GA requirement,  if you do not provide those two variables on the event ( with any other variable you want to pass) The  GA library will not fire the pixel for the event. 

Highlighted

custom metric not being captured

Gold Contributor
Gold Contributor
@lukas_teply

Please go through the following https://community.tealiumiq.com/t5/Tealium-iQ/How-To-Guide-Event-Tracking-With-Google-Analytics/ta-p... link.

Hope it will cover your requirements.
Highlighted

custom metric not being captured

Silver Contributor
Silver Contributor
Hi, thank you. We got it finally working and now it is being collected.
Highlighted

custom metric not being captured

Gold Contributor
Gold Contributor
@lukas_teply No problem. It's my pleasure.
Highlighted

custom metric not being captured

Bronze Contributor
Bronze Contributor

Hi @lukas_teply,

i facing same issue. how did you able to get fixed ?

 

Thanks in advance,

Girish